Uploaded image for project: 'Pegasus'
  1. Pegasus
  2. PM-781

PegasusLite uses wrong worker package on Mac OS X

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: master, 4.4.0
    • Fix Version/s: master
    • Labels:
      None

      Description

      When I try to run a workflow with PegasusLite using Mac OS workers the PegasusLite script tries to download a RHEL5 worker package:

      2014-09-03 11:19:50: PegasusLite: version 4.5.0cvs
      2014-09-03 11:19:50: Not creating a new work directory as it is already set to /private/var/lib/condor/dir_81970
      2014-09-03 11:19:50: Pegasus binaries in /usr/bin do not match Pegasus version used for current workflow
      2014-09-03 11:19:50: Downloading Pegasus worker package from http://download.pegasus.isi.edu/pegasus/4.5.0cvs/pegasus-worker-4.5.0cvs-x86_64_rhel_5.tar.gz
      /var/lib/condor/dir_81970/condor_exec.exe: line 26: /private/var/lib/condor/dir_81970/pegasus-4.5.0cvs/bin/pegasus-kickstart: cannot execute binary file
      2014-09-03 11:19:50: Job failed with exitcode 126
      2014-09-03 11:19:50: FAILURE: Last command exited with 126
      PegasusLite: exitcode 126

        Attachments

          Activity

            People

            • Assignee:
              rynge Mats Rynge
              Reporter:
              gideon Gideon Juve (Inactive)
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: