Uploaded image for project: 'Pegasus'
  1. Pegasus
  2. PM-1290

Queue is not handled correctly in Glite

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: master, 4.9.0, 4.8.3
    • Fix Version/s: master, 4.9.0, 4.8.4
    • Component/s: None
    • Labels:
      None

      Description

      In Glite mode, I have set pegasus,queue but I only see it being carried through to +remote_environment, and not +remote_cerequirements (which is where we need it). For example:

      +remote_cerequirements = JOBNAME=="chmodmergeuq0" && PASSENV==1 && NODES=="1" && CORES=="1" && WALLTIME=="04:00:00" && PROJECT=="DesignSafe-McKenna" && PRIORITY==800
      +remote_environment = "PEGASUS_HOME=/home/00384/rynge/software/pegasus/4.9.0dev CONDOR_JOBID=$(cluster).$(process) PEGASUS_WF_UUID=453a488e-0255-4e2e-bb25-1a634c7d3d16 PEGASUS_WF_LABEL=000001 PEGASUS_DAG_JOB_ID=chmod_merge_uq_0 PEGASUS_SITE=compute PEGASUS_SCRATCH_DIR=/gpfs/flash/users/rynge/wf-scratch/20180815162530/00/00/000001_ID0000001 PEGASUS_NODES=1 PEGASUS_RUNTIME=14400 PEGASUS_CORES=1 PEGASUS_PROJECT=DesignSafe-McKenna PEGASUS_QUEUE=normal"

        Attachments

          Activity

            People

            • Assignee:
              vahi Karan Vahi
              Reporter:
              rynge Mats Rynge
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: