Or notifications should be named more consistently. Currently we have:
The on_ and at_ are only applied to a few of them. A cleaner set would be:
The other problem is that "end" and "all" are really aliases for a set of notifications, but when the callout takes place, it is this meta event which is listed and not the real event. For example: if you have "end" specified, the notification says "end" instead of "success" or "error". I think the event should be listed as a specific as possible event so that the notification script can use that information internally.